25 lines
975 B
Diff
25 lines
975 B
Diff
From: Ben Hutchings <ben@decadent.org.uk>
|
|
Subject: Make mkcompile_h accept an alternate timestamp string
|
|
Date: Tue, 12 May 2015 19:29:22 +0100
|
|
Forwarded: not-needed
|
|
|
|
We want to include the Debian version in the utsname::version string
|
|
instead of a full timestamp string. However, we still need to provide
|
|
a standard timestamp string for gen_initramfs_list.sh to make the
|
|
kernel image reproducible.
|
|
|
|
Make mkcompile_h use $KBUILD_BUILD_VERSION_TIMESTAMP in preference to
|
|
$KBUILD_BUILD_TIMESTAMP.
|
|
|
|
--- a/init/Makefile
|
|
+++ b/init/Makefile
|
|
@@ -29,7 +29,7 @@ preempt-flag-$(CONFIG_PREEMPT_DYNAMIC) :
|
|
preempt-flag-$(CONFIG_PREEMPT_RT) := PREEMPT_RT
|
|
|
|
build-version = $(or $(KBUILD_BUILD_VERSION), $(build-version-auto))
|
|
-build-timestamp = $(or $(KBUILD_BUILD_TIMESTAMP), $(build-timestamp-auto))
|
|
+build-timestamp = $(or $(KBUILD_BUILD_VERSION_TIMESTAMP), $(KBUILD_BUILD_TIMESTAMP), $(build-timestamp-auto))
|
|
|
|
# Maximum length of UTS_VERSION is 64 chars
|
|
filechk_uts_version = \
|