Konstantin Demin
c3d09a3e94
imported from https://salsa.debian.org/kernel-team/linux.git commit 9d5cc9d9d6501d7f1dd7e194d4b245bd0b6c6a22 version 6.11.4-1
63 lines
2.2 KiB
Diff
63 lines
2.2 KiB
Diff
From: Ben Hutchings <ben@decadent.org.uk>
|
|
Date: Fri, 22 Jun 2018 17:27:00 +0100
|
|
Subject: android: Enable building ashmem and binder as modules
|
|
Bug-Debian: https://bugs.debian.org/901492
|
|
|
|
We want to enable use of the Android ashmem and binder drivers to
|
|
support Anbox, but they should not be built-in as that would waste
|
|
resources and increase security attack surface on systems that don't
|
|
need them.
|
|
|
|
- Add a MODULE_LICENSE declaration to ashmem
|
|
- Change the Makefiles to build each driver as an object with the
|
|
"_linux" suffix (which is what Anbox expects)
|
|
- Change config symbol types to tristate
|
|
|
|
Update:
|
|
In upstream commit 721412ed3d titled "staging: remove ashmem" the ashmem
|
|
driver was removed entirely. Secondary commit message:
|
|
"The mainline replacement for ashmem is memfd, so remove the legacy
|
|
code from drivers/staging/"
|
|
Consequently, the ashmem part of this patch has been removed.
|
|
---
|
|
drivers/android/Kconfig | 2 +-
|
|
drivers/android/Makefile | 7 ++++---
|
|
drivers/android/binder_alloc.c | 2 +-
|
|
3 files changed, 6 insertions(+), 5 deletions(-)
|
|
|
|
--- a/drivers/android/Kconfig
|
|
+++ b/drivers/android/Kconfig
|
|
@@ -2,7 +2,7 @@
|
|
menu "Android"
|
|
|
|
config ANDROID_BINDER_IPC
|
|
- bool "Android Binder IPC Driver"
|
|
+ tristate "Android Binder IPC Driver"
|
|
depends on MMU
|
|
default n
|
|
help
|
|
--- a/drivers/android/Makefile
|
|
+++ b/drivers/android/Makefile
|
|
@@ -1,6 +1,7 @@
|
|
# SPDX-License-Identifier: GPL-2.0-only
|
|
ccflags-y += -I$(src) # needed for trace events
|
|
|
|
-obj-$(CONFIG_ANDROID_BINDERFS) += binderfs.o
|
|
-obj-$(CONFIG_ANDROID_BINDER_IPC) += binder.o binder_alloc.o
|
|
-obj-$(CONFIG_ANDROID_BINDER_IPC_SELFTEST) += binder_alloc_selftest.o
|
|
+obj-$(CONFIG_ANDROID_BINDER_IPC) += binder_linux.o
|
|
+binder_linux-y := binder.o binder_alloc.o
|
|
+binder_linux-$(CONFIG_ANDROID_BINDERFS) += binderfs.o
|
|
+binder_linux-$(CONFIG_ANDROID_BINDER_IPC_SELFTEST) += binder_alloc_selftest.o
|
|
--- a/drivers/android/binder_alloc.c
|
|
+++ b/drivers/android/binder_alloc.c
|
|
@@ -38,7 +38,7 @@ enum {
|
|
};
|
|
static uint32_t binder_alloc_debug_mask = BINDER_DEBUG_USER_ERROR;
|
|
|
|
-module_param_named(debug_mask, binder_alloc_debug_mask,
|
|
+module_param_named(alloc_debug_mask, binder_alloc_debug_mask,
|
|
uint, 0644);
|
|
|
|
#define binder_alloc_debug(mask, x...) \
|