38 lines
1.5 KiB
Diff
38 lines
1.5 KiB
Diff
From: Krzysztof Kozlowski <krzk@kernel.org>
|
|
Date: Wed, 29 Aug 2018 09:32:23 +0200
|
|
Subject: powerpc/boot: Fix missing crc32poly.h when building with KERNEL_XZ
|
|
Origin: https://patchwork.ozlabs.org/patch/963258/
|
|
|
|
After commit faa16bc404d7 ("lib: Use existing define with
|
|
polynomial") the lib/xz/xz_crc32.c includes a header from include/linux
|
|
directory thus any other user of this code should define proper include
|
|
path.
|
|
|
|
This fixes the build error on powerpc with CONFIG_KERNEL_XZ:
|
|
|
|
In file included from ../arch/powerpc/boot/../../../lib/decompress_unxz.c:233:0,
|
|
from ../arch/powerpc/boot/decompress.c:42:
|
|
../arch/powerpc/boot/../../../lib/xz/xz_crc32.c:18:29: fatal error: linux/crc32poly.h: No such file or directory
|
|
|
|
Reported-by: Michal Kubecek <mkubecek@suse.cz>
|
|
Fixes: faa16bc404d7 ("lib: Use existing define with polynomial")
|
|
Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
|
|
Reported-by: kbuild test robot <lkp@intel.com>
|
|
Reported-by: Meelis Roos <mroos@linux.ee>
|
|
Tested-by: Michal Kubecek <mkubecek@suse.cz>
|
|
---
|
|
arch/powerpc/boot/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -97,7 +97,7 @@ BOOTCFLAGS += -fno-stack-protector
|
|
endif
|
|
|
|
BOOTCFLAGS += -include $(srctree)/include/linux/compiler_attributes.h
|
|
-BOOTCFLAGS += -I$(objtree)/$(obj) -I$(srctree)/$(obj)
|
|
+BOOTCFLAGS += -I$(objtree)/$(obj) -I$(srctree)/$(obj) -I$(srctree)/include
|
|
|
|
DTC_FLAGS ?= -p 1024
|
|
|