Konstantin Demin
c3d09a3e94
imported from https://salsa.debian.org/kernel-team/linux.git commit 9d5cc9d9d6501d7f1dd7e194d4b245bd0b6c6a22 version 6.11.4-1
24 lines
833 B
Diff
24 lines
833 B
Diff
From: Ben Hutchings <ben@decadent.org.uk>
|
|
Subject: kbuild: Fix recordmcount dependency for OOT modules
|
|
Date: Mon, 08 Sep 2014 18:31:24 +0100
|
|
Forwarded: no
|
|
|
|
We never rebuild anything in-tree when building an out-of-tree
|
|
modules, so external modules should not depend on the recordmcount
|
|
sources.
|
|
|
|
--- a/scripts/Makefile.build
|
|
+++ b/scripts/Makefile.build
|
|
@@ -210,6 +210,11 @@ cmd_record_mcount = $(if $(findstring $(
|
|
$(sub_cmd_record_mcount))
|
|
endif # CONFIG_FTRACE_MCOUNT_USE_RECORDMCOUNT
|
|
|
|
+# Don't require recordmcount source for an OOT build.
|
|
+ifdef KBUILD_EXTMOD
|
|
+recordmcount_source :=
|
|
+endif
|
|
+
|
|
# 'OBJECT_FILES_NON_STANDARD := y': skip objtool checking for a directory
|
|
# 'OBJECT_FILES_NON_STANDARD_foo.o := 'y': skip objtool checking for a file
|
|
# 'OBJECT_FILES_NON_STANDARD_foo.o := 'n': override directory skip for a file
|