Konstantin Demin
c3d09a3e94
imported from https://salsa.debian.org/kernel-team/linux.git commit 9d5cc9d9d6501d7f1dd7e194d4b245bd0b6c6a22 version 6.11.4-1
96 lines
3.6 KiB
Diff
96 lines
3.6 KiB
Diff
From: Ben Hutchings <ben@decadent.org.uk>
|
|
Date: Mon, 07 Feb 2022 00:00:26 +0100
|
|
Subject: sh: Do not use hyphen in exported variable names
|
|
|
|
arch/sh/Makefile defines and exports ld-bfd to be used by
|
|
arch/sh/boot/Makefile and arch/sh/boot/compressed/Makefile. However
|
|
some shells, including dash, will not pass through environment
|
|
variables whose name includes a hyphen. Usually GNU make does not use
|
|
a shell to recurse, but if e.g. $(srctree) contains '~' it will use a
|
|
shell here.
|
|
|
|
Rename the variable to ld_bfd.
|
|
|
|
(Another instance of this problem was fixed upstream by commit
|
|
82977af93a0d "sh: rename suffix-y to suffix_y".)
|
|
|
|
References: https://buildd.debian.org/status/fetch.php?pkg=linux&arch=sh4&ver=4.13%7Erc5-1%7Eexp1&stamp=1502943967&raw=0
|
|
Fixes: ef9b542fce00 ("sh: bzip2/lzma uImage support.")
|
|
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
|
|
---
|
|
arch/sh/Makefile | 10 +++++-----
|
|
arch/sh/boot/compressed/Makefile | 4 ++--
|
|
arch/sh/boot/romimage/Makefile | 4 ++--
|
|
3 files changed, 9 insertions(+), 9 deletions(-)
|
|
|
|
Index: linux/arch/sh/Makefile
|
|
===================================================================
|
|
--- linux.orig/arch/sh/Makefile
|
|
+++ linux/arch/sh/Makefile
|
|
@@ -102,16 +102,16 @@ UTS_MACHINE := sh
|
|
LDFLAGS_vmlinux += -e _stext
|
|
|
|
ifdef CONFIG_CPU_LITTLE_ENDIAN
|
|
-ld-bfd := elf32-sh-linux
|
|
-LDFLAGS_vmlinux += --defsym jiffies=jiffies_64 --oformat $(ld-bfd)
|
|
+ld_bfd := elf32-sh-linux
|
|
+LDFLAGS_vmlinux += --defsym jiffies=jiffies_64 --oformat $(ld_bfd)
|
|
KBUILD_LDFLAGS += -EL
|
|
else
|
|
-ld-bfd := elf32-shbig-linux
|
|
-LDFLAGS_vmlinux += --defsym jiffies=jiffies_64+4 --oformat $(ld-bfd)
|
|
+ld_bfd := elf32-shbig-linux
|
|
+LDFLAGS_vmlinux += --defsym jiffies=jiffies_64+4 --oformat $(ld_bfd)
|
|
KBUILD_LDFLAGS += -EB
|
|
endif
|
|
|
|
-export ld-bfd
|
|
+export ld_bfd
|
|
|
|
# Mach groups
|
|
machdir-$(CONFIG_SOLUTION_ENGINE) += mach-se
|
|
Index: linux/arch/sh/boot/compressed/Makefile
|
|
===================================================================
|
|
--- linux.orig/arch/sh/boot/compressed/Makefile
|
|
+++ linux/arch/sh/boot/compressed/Makefile
|
|
@@ -36,7 +36,7 @@ endif
|
|
|
|
ccflags-remove-$(CONFIG_MCOUNT) += -pg
|
|
|
|
-LDFLAGS_vmlinux := --oformat $(ld-bfd) -Ttext $(IMAGE_OFFSET) -e startup \
|
|
+LDFLAGS_vmlinux := --oformat $(ld_bfd) -Ttext $(IMAGE_OFFSET) -e startup \
|
|
-T $(obj)/../../kernel/vmlinux.lds
|
|
|
|
KBUILD_CFLAGS += -DDISABLE_BRANCH_PROFILING
|
|
@@ -60,7 +60,7 @@ $(obj)/vmlinux.bin.lzo: $(obj)/vmlinux.b
|
|
|
|
OBJCOPYFLAGS += -R .empty_zero_page
|
|
|
|
-LDFLAGS_piggy.o := -r --format binary --oformat $(ld-bfd) -T
|
|
+LDFLAGS_piggy.o := -r --format binary --oformat $(ld_bfd) -T
|
|
|
|
$(obj)/piggy.o: $(obj)/vmlinux.scr $(obj)/vmlinux.bin.$(suffix_y) FORCE
|
|
$(call if_changed,ld)
|
|
Index: linux/arch/sh/boot/romimage/Makefile
|
|
===================================================================
|
|
--- linux.orig/arch/sh/boot/romimage/Makefile
|
|
+++ linux/arch/sh/boot/romimage/Makefile
|
|
@@ -13,7 +13,7 @@ mmcif-obj-$(CONFIG_CPU_SUBTYPE_SH7724) :
|
|
load-$(CONFIG_ROMIMAGE_MMCIF) := $(mmcif-load-y)
|
|
obj-$(CONFIG_ROMIMAGE_MMCIF) := $(mmcif-obj-y)
|
|
|
|
-LDFLAGS_vmlinux := --oformat $(ld-bfd) -Ttext $(load-y) -e romstart \
|
|
+LDFLAGS_vmlinux := --oformat $(ld_bfd) -Ttext $(load-y) -e romstart \
|
|
-T $(obj)/../../kernel/vmlinux.lds
|
|
|
|
$(obj)/vmlinux: $(obj)/head.o $(obj-y) $(obj)/piggy.o FORCE
|
|
@@ -24,7 +24,7 @@ OBJCOPYFLAGS += -j .empty_zero_page
|
|
$(obj)/zeropage.bin: vmlinux FORCE
|
|
$(call if_changed,objcopy)
|
|
|
|
-LDFLAGS_piggy.o := -r --format binary --oformat $(ld-bfd) -T
|
|
+LDFLAGS_piggy.o := -r --format binary --oformat $(ld_bfd) -T
|
|
|
|
$(obj)/piggy.o: $(obj)/vmlinux.scr $(obj)/zeropage.bin arch/sh/boot/zImage FORCE
|
|
$(call if_changed,ld)
|