44 lines
1.3 KiB
Diff
44 lines
1.3 KiB
Diff
From f94f6415c70f76d885dd542e8631f826f427941e Mon Sep 17 00:00:00 2001
|
|
From: Dhananjay Ugwekar <Dhananjay.Ugwekar@amd.com>
|
|
Date: Wed, 4 Dec 2024 14:48:41 +0000
|
|
Subject: cpufreq/amd-pstate: Remove the cppc_state check in offline/online
|
|
functions
|
|
|
|
Only amd_pstate_epp driver (i.e. cppc_state = ACTIVE) enters the
|
|
amd_pstate_epp_offline() and amd_pstate_epp_cpu_online() functions,
|
|
so remove the unnecessary if condition checking if cppc_state is
|
|
equal to AMD_PSTATE_ACTIVE.
|
|
|
|
Signed-off-by: Dhananjay Ugwekar <Dhananjay.Ugwekar@amd.com>
|
|
Reviewed-by: Mario Limonciello <mario.limonciello@amd.com>
|
|
Reviewed-by: Gautham R. Shenoy <gautham.shenoy@amd.com>
|
|
---
|
|
drivers/cpufreq/amd-pstate.c | 9 +++------
|
|
1 file changed, 3 insertions(+), 6 deletions(-)
|
|
|
|
--- a/drivers/cpufreq/amd-pstate.c
|
|
+++ b/drivers/cpufreq/amd-pstate.c
|
|
@@ -1679,10 +1679,8 @@ static int amd_pstate_epp_cpu_online(str
|
|
|
|
pr_debug("AMD CPU Core %d going online\n", cpudata->cpu);
|
|
|
|
- if (cppc_state == AMD_PSTATE_ACTIVE) {
|
|
- amd_pstate_epp_reenable(cpudata);
|
|
- cpudata->suspended = false;
|
|
- }
|
|
+ amd_pstate_epp_reenable(cpudata);
|
|
+ cpudata->suspended = false;
|
|
|
|
return 0;
|
|
}
|
|
@@ -1711,8 +1709,7 @@ static int amd_pstate_epp_cpu_offline(st
|
|
if (cpudata->suspended)
|
|
return 0;
|
|
|
|
- if (cppc_state == AMD_PSTATE_ACTIVE)
|
|
- amd_pstate_epp_offline(policy);
|
|
+ amd_pstate_epp_offline(policy);
|
|
|
|
return 0;
|
|
}
|