55 lines
1.8 KiB
Diff
55 lines
1.8 KiB
Diff
From 2a012fdcef91db6e380000b8042f90544ea49fd7 Mon Sep 17 00:00:00 2001
|
|
From: Dhananjay Ugwekar <Dhananjay.Ugwekar@amd.com>
|
|
Date: Thu, 17 Oct 2024 05:39:28 +0000
|
|
Subject: cpufreq/amd-pstate: Remove the redundant verify() function
|
|
|
|
Merge the two verify() callback functions and rename the
|
|
cpufreq_policy_data argument for better readability.
|
|
|
|
Signed-off-by: Dhananjay Ugwekar <Dhananjay.Ugwekar@amd.com>
|
|
Reviewed-by: Mario Limonciello <mario.limonciello@amd.com>
|
|
Reviewed-by: Gautham R. Shenoy <gautham.shenoy@amd.com>
|
|
---
|
|
drivers/cpufreq/amd-pstate.c | 15 ++++-----------
|
|
1 file changed, 4 insertions(+), 11 deletions(-)
|
|
|
|
--- a/drivers/cpufreq/amd-pstate.c
|
|
+++ b/drivers/cpufreq/amd-pstate.c
|
|
@@ -557,10 +557,10 @@ cpufreq_policy_put:
|
|
cpufreq_cpu_put(policy);
|
|
}
|
|
|
|
-static int amd_pstate_verify(struct cpufreq_policy_data *policy)
|
|
+static int amd_pstate_verify(struct cpufreq_policy_data *policy_data)
|
|
{
|
|
- cpufreq_verify_within_cpu_limits(policy);
|
|
-
|
|
+ cpufreq_verify_within_cpu_limits(policy_data);
|
|
+ pr_debug("policy_max =%d, policy_min=%d\n", policy_data->max, policy_data->min);
|
|
return 0;
|
|
}
|
|
|
|
@@ -1668,13 +1668,6 @@ static int amd_pstate_epp_cpu_offline(st
|
|
return 0;
|
|
}
|
|
|
|
-static int amd_pstate_epp_verify_policy(struct cpufreq_policy_data *policy)
|
|
-{
|
|
- cpufreq_verify_within_cpu_limits(policy);
|
|
- pr_debug("policy_max =%d, policy_min=%d\n", policy->max, policy->min);
|
|
- return 0;
|
|
-}
|
|
-
|
|
static int amd_pstate_epp_suspend(struct cpufreq_policy *policy)
|
|
{
|
|
struct amd_cpudata *cpudata = policy->driver_data;
|
|
@@ -1730,7 +1723,7 @@ static struct cpufreq_driver amd_pstate_
|
|
|
|
static struct cpufreq_driver amd_pstate_epp_driver = {
|
|
.flags = CPUFREQ_CONST_LOOPS,
|
|
- .verify = amd_pstate_epp_verify_policy,
|
|
+ .verify = amd_pstate_verify,
|
|
.setpolicy = amd_pstate_epp_set_policy,
|
|
.init = amd_pstate_epp_cpu_init,
|
|
.exit = amd_pstate_epp_cpu_exit,
|