23 lines
776 B
Diff
23 lines
776 B
Diff
From: Ben Hutchings <ben@decadent.org.uk>
|
|
Subject: fs: Enable link security restrictions by default
|
|
Date: Fri, 02 Nov 2012 05:32:06 +0000
|
|
Bug-Debian: https://bugs.debian.org/609455
|
|
Forwarded: not-needed
|
|
|
|
This reverts commit 561ec64ae67ef25cac8d72bb9c4bfc955edfd415
|
|
('VFS: don't do protected {sym,hard}links by default').
|
|
|
|
--- a/fs/namei.c
|
|
+++ b/fs/namei.c
|
|
@@ -1034,8 +1034,8 @@ static inline void put_link(struct namei
|
|
path_put(&last->link);
|
|
}
|
|
|
|
-static int sysctl_protected_symlinks __read_mostly;
|
|
-static int sysctl_protected_hardlinks __read_mostly;
|
|
+static int sysctl_protected_symlinks __read_mostly = 1;
|
|
+static int sysctl_protected_hardlinks __read_mostly = 1;
|
|
static int sysctl_protected_fifos __read_mostly;
|
|
static int sysctl_protected_regular __read_mostly;
|
|
|