Konstantin Demin
8cbaf1dea2
3rd patchs (in alphabetical order): - bbr3 - ntsync5 - openwrt - pf-kernel - xanmod - zen no configuration changes for now
48 lines
1.6 KiB
Diff
48 lines
1.6 KiB
Diff
From dbc0343069c8f86fad0d8d9075f70f79114ef10a Mon Sep 17 00:00:00 2001
|
|
From: Dhananjay Ugwekar <Dhananjay.Ugwekar@amd.com>
|
|
Date: Fri, 13 Sep 2024 15:47:59 +0000
|
|
Subject: perf/x86/rapl: Remove the global variable rapl_msrs
|
|
|
|
After making the rapl_model struct global, the rapl_msrs global
|
|
variable isn't needed, so remove it.
|
|
|
|
Also it will be cleaner when new per-core scope PMU is added. As we will
|
|
need to maintain two rapl_msrs array(one for per-core scope and one for
|
|
package scope PMU), inside the rapl_model struct.
|
|
|
|
Signed-off-by: Dhananjay Ugwekar <Dhananjay.Ugwekar@amd.com>
|
|
---
|
|
arch/x86/events/rapl.c | 7 ++-----
|
|
1 file changed, 2 insertions(+), 5 deletions(-)
|
|
|
|
--- a/arch/x86/events/rapl.c
|
|
+++ b/arch/x86/events/rapl.c
|
|
@@ -137,7 +137,6 @@ static int rapl_pkg_hw_unit[NR_RAPL_PKG_
|
|
static struct rapl_pmus *rapl_pmus_pkg;
|
|
static unsigned int rapl_pkg_cntr_mask;
|
|
static u64 rapl_timer_ms;
|
|
-static struct perf_msr *rapl_msrs;
|
|
static struct rapl_model *rapl_model;
|
|
|
|
/*
|
|
@@ -376,7 +375,7 @@ static int rapl_pmu_event_init(struct pe
|
|
return -EINVAL;
|
|
|
|
event->pmu_private = rapl_pmu;
|
|
- event->hw.event_base = rapl_msrs[bit].msr;
|
|
+ event->hw.event_base = rapl_model->rapl_pkg_msrs[bit].msr;
|
|
event->hw.config = cfg;
|
|
event->hw.idx = bit;
|
|
|
|
@@ -813,9 +812,7 @@ static int __init rapl_pmu_init(void)
|
|
|
|
rapl_model = (struct rapl_model *) id->driver_data;
|
|
|
|
- rapl_msrs = rapl_model->rapl_pkg_msrs;
|
|
-
|
|
- rapl_pkg_cntr_mask = perf_msr_probe(rapl_msrs, PERF_RAPL_PKG_EVENTS_MAX,
|
|
+ rapl_pkg_cntr_mask = perf_msr_probe(rapl_model->rapl_pkg_msrs, PERF_RAPL_PKG_EVENTS_MAX,
|
|
false, (void *) &rapl_model->pkg_events);
|
|
|
|
ret = rapl_check_hw_unit();
|