184 lines
5.8 KiB
Diff
184 lines
5.8 KiB
Diff
From 27b069b518f77fffc337286a2fad8a6305daa60f Mon Sep 17 00:00:00 2001
|
|
From: Mario Limonciello <mario.limonciello@amd.com>
|
|
Date: Mon, 4 Nov 2024 16:28:55 -0600
|
|
Subject: ACPI: processor: Move arch_init_invariance_cppc() call later
|
|
|
|
arch_init_invariance_cppc() is called at the end of
|
|
acpi_cppc_processor_probe() in order to configure frequency invariance
|
|
based upon the values from _CPC.
|
|
|
|
This however doesn't work on AMD CPPC shared memory designs that have
|
|
AMD preferred cores enabled because _CPC needs to be analyzed from all
|
|
cores to judge if preferred cores are enabled.
|
|
|
|
This issue manifests to users as a warning since commit 21fb59ab4b97
|
|
("ACPI: CPPC: Adjust debug messages in amd_set_max_freq_ratio() to warn"):
|
|
```
|
|
Could not retrieve highest performance (-19)
|
|
```
|
|
|
|
However the warning isn't the cause of this, it was actually
|
|
commit 279f838a61f9 ("x86/amd: Detect preferred cores in
|
|
amd_get_boost_ratio_numerator()") which exposed the issue.
|
|
|
|
To fix this problem, change arch_init_invariance_cppc() into a new weak
|
|
symbol that is called at the end of acpi_processor_driver_init().
|
|
Each architecture that supports it can declare the symbol to override
|
|
the weak one.
|
|
|
|
Fixes: 279f838a61f9 ("x86/amd: Detect preferred cores in amd_get_boost_ratio_numerator()")
|
|
Reported-by: Ivan Shapovalov <intelfx@intelfx.name>
|
|
Closes: https://bugzilla.kernel.org/show_bug.cgi?id=219431
|
|
Tested-by: Oleksandr Natalenko <oleksandr@natalenko.name>
|
|
Signed-off-by: Mario Limonciello <mario.limonciello@amd.com>
|
|
---
|
|
arch/arm64/include/asm/topology.h | 4 ----
|
|
arch/x86/include/asm/topology.h | 5 -----
|
|
arch/x86/kernel/acpi/cppc.c | 7 ++++++-
|
|
drivers/acpi/cppc_acpi.c | 6 ------
|
|
drivers/acpi/processor_driver.c | 9 +++++++++
|
|
drivers/base/arch_topology.c | 6 +++++-
|
|
include/acpi/processor.h | 2 ++
|
|
include/linux/arch_topology.h | 4 ----
|
|
8 files changed, 22 insertions(+), 21 deletions(-)
|
|
|
|
--- a/arch/arm64/include/asm/topology.h
|
|
+++ b/arch/arm64/include/asm/topology.h
|
|
@@ -25,10 +25,6 @@ void update_freq_counters_refs(void);
|
|
#define arch_scale_freq_invariant topology_scale_freq_invariant
|
|
#define arch_scale_freq_ref topology_get_freq_ref
|
|
|
|
-#ifdef CONFIG_ACPI_CPPC_LIB
|
|
-#define arch_init_invariance_cppc topology_init_cpu_capacity_cppc
|
|
-#endif
|
|
-
|
|
/* Replace task scheduler's default cpu-invariant accounting */
|
|
#define arch_scale_cpu_capacity topology_get_cpu_scale
|
|
|
|
--- a/arch/x86/include/asm/topology.h
|
|
+++ b/arch/x86/include/asm/topology.h
|
|
@@ -292,9 +292,4 @@ static inline void freq_invariance_set_p
|
|
extern void arch_scale_freq_tick(void);
|
|
#define arch_scale_freq_tick arch_scale_freq_tick
|
|
|
|
-#ifdef CONFIG_ACPI_CPPC_LIB
|
|
-void init_freq_invariance_cppc(void);
|
|
-#define arch_init_invariance_cppc init_freq_invariance_cppc
|
|
-#endif
|
|
-
|
|
#endif /* _ASM_X86_TOPOLOGY_H */
|
|
--- a/arch/x86/kernel/acpi/cppc.c
|
|
+++ b/arch/x86/kernel/acpi/cppc.c
|
|
@@ -110,7 +110,7 @@ static void amd_set_max_freq_ratio(void)
|
|
|
|
static DEFINE_MUTEX(freq_invariance_lock);
|
|
|
|
-void init_freq_invariance_cppc(void)
|
|
+static inline void init_freq_invariance_cppc(void)
|
|
{
|
|
static bool init_done;
|
|
|
|
@@ -127,6 +127,11 @@ void init_freq_invariance_cppc(void)
|
|
mutex_unlock(&freq_invariance_lock);
|
|
}
|
|
|
|
+void acpi_processor_init_invariance_cppc(void)
|
|
+{
|
|
+ init_freq_invariance_cppc();
|
|
+}
|
|
+
|
|
/*
|
|
* Get the highest performance register value.
|
|
* @cpu: CPU from which to get highest performance.
|
|
--- a/drivers/acpi/cppc_acpi.c
|
|
+++ b/drivers/acpi/cppc_acpi.c
|
|
@@ -671,10 +671,6 @@ static int pcc_data_alloc(int pcc_ss_id)
|
|
* )
|
|
*/
|
|
|
|
-#ifndef arch_init_invariance_cppc
|
|
-static inline void arch_init_invariance_cppc(void) { }
|
|
-#endif
|
|
-
|
|
/**
|
|
* acpi_cppc_processor_probe - Search for per CPU _CPC objects.
|
|
* @pr: Ptr to acpi_processor containing this CPU's logical ID.
|
|
@@ -905,8 +901,6 @@ int acpi_cppc_processor_probe(struct acp
|
|
goto out_free;
|
|
}
|
|
|
|
- arch_init_invariance_cppc();
|
|
-
|
|
kfree(output.pointer);
|
|
return 0;
|
|
|
|
--- a/drivers/acpi/processor_driver.c
|
|
+++ b/drivers/acpi/processor_driver.c
|
|
@@ -237,6 +237,9 @@ static struct notifier_block acpi_proces
|
|
.notifier_call = acpi_processor_notifier,
|
|
};
|
|
|
|
+void __weak acpi_processor_init_invariance_cppc(void)
|
|
+{ }
|
|
+
|
|
/*
|
|
* We keep the driver loaded even when ACPI is not running.
|
|
* This is needed for the powernow-k8 driver, that works even without
|
|
@@ -270,6 +273,12 @@ static int __init acpi_processor_driver_
|
|
NULL, acpi_soft_cpu_dead);
|
|
|
|
acpi_processor_throttling_init();
|
|
+
|
|
+ /*
|
|
+ * Frequency invariance calculations on AMD platforms can't be run until
|
|
+ * after acpi_cppc_processor_probe() has been called for all online CPUs
|
|
+ */
|
|
+ acpi_processor_init_invariance_cppc();
|
|
return 0;
|
|
err:
|
|
driver_unregister(&acpi_processor_driver);
|
|
--- a/drivers/base/arch_topology.c
|
|
+++ b/drivers/base/arch_topology.c
|
|
@@ -366,7 +366,7 @@ void __weak freq_inv_set_max_ratio(int c
|
|
#ifdef CONFIG_ACPI_CPPC_LIB
|
|
#include <acpi/cppc_acpi.h>
|
|
|
|
-void topology_init_cpu_capacity_cppc(void)
|
|
+static inline void topology_init_cpu_capacity_cppc(void)
|
|
{
|
|
u64 capacity, capacity_scale = 0;
|
|
struct cppc_perf_caps perf_caps;
|
|
@@ -417,6 +417,10 @@ void topology_init_cpu_capacity_cppc(voi
|
|
exit:
|
|
free_raw_capacity();
|
|
}
|
|
+void acpi_processor_init_invariance_cppc(void)
|
|
+{
|
|
+ topology_init_cpu_capacity_cppc();
|
|
+}
|
|
#endif
|
|
|
|
#ifdef CONFIG_CPU_FREQ
|
|
--- a/include/acpi/processor.h
|
|
+++ b/include/acpi/processor.h
|
|
@@ -465,4 +465,6 @@ extern int acpi_processor_ffh_lpi_probe(
|
|
extern int acpi_processor_ffh_lpi_enter(struct acpi_lpi_state *lpi);
|
|
#endif
|
|
|
|
+void acpi_processor_init_invariance_cppc(void);
|
|
+
|
|
#endif
|
|
--- a/include/linux/arch_topology.h
|
|
+++ b/include/linux/arch_topology.h
|
|
@@ -11,10 +11,6 @@
|
|
void topology_normalize_cpu_scale(void);
|
|
int topology_update_cpu_topology(void);
|
|
|
|
-#ifdef CONFIG_ACPI_CPPC_LIB
|
|
-void topology_init_cpu_capacity_cppc(void);
|
|
-#endif
|
|
-
|
|
struct device_node;
|
|
bool topology_parse_cpu_capacity(struct device_node *cpu_node, int cpu);
|
|
|