Konstantin Demin
8cbaf1dea2
3rd patchs (in alphabetical order): - bbr3 - ntsync5 - openwrt - pf-kernel - xanmod - zen no configuration changes for now
61 lines
2.0 KiB
Diff
61 lines
2.0 KiB
Diff
From 99bca5d776a3011214041c42107a210fe315a35e Mon Sep 17 00:00:00 2001
|
|
From: Elizabeth Figura <zfigura@codeweavers.com>
|
|
Date: Sun, 19 May 2024 15:24:35 -0500
|
|
Subject: ntsync: Introduce NTSYNC_IOC_EVENT_PULSE.
|
|
|
|
This corresponds to the NT syscall NtPulseEvent().
|
|
|
|
This wakes up any waiters as if the event had been set, but does not set the
|
|
event, instead resetting it if it had been signalled. Thus, for a manual-reset
|
|
event, all waiters are woken, whereas for an auto-reset event, at most one
|
|
waiter is woken.
|
|
|
|
Signed-off-by: Elizabeth Figura <zfigura@codeweavers.com>
|
|
---
|
|
drivers/misc/ntsync.c | 8 ++++++--
|
|
include/uapi/linux/ntsync.h | 1 +
|
|
2 files changed, 7 insertions(+), 2 deletions(-)
|
|
|
|
--- a/drivers/misc/ntsync.c
|
|
+++ b/drivers/misc/ntsync.c
|
|
@@ -534,7 +534,7 @@ static int ntsync_mutex_kill(struct ntsy
|
|
return ret;
|
|
}
|
|
|
|
-static int ntsync_event_set(struct ntsync_obj *event, void __user *argp)
|
|
+static int ntsync_event_set(struct ntsync_obj *event, void __user *argp, bool pulse)
|
|
{
|
|
struct ntsync_device *dev = event->dev;
|
|
__u32 prev_state;
|
|
@@ -550,6 +550,8 @@ static int ntsync_event_set(struct ntsyn
|
|
if (all)
|
|
try_wake_all_obj(dev, event);
|
|
try_wake_any_event(event);
|
|
+ if (pulse)
|
|
+ event->u.event.signaled = false;
|
|
|
|
ntsync_unlock_obj(dev, event, all);
|
|
|
|
@@ -605,9 +607,11 @@ static long ntsync_obj_ioctl(struct file
|
|
case NTSYNC_IOC_MUTEX_KILL:
|
|
return ntsync_mutex_kill(obj, argp);
|
|
case NTSYNC_IOC_EVENT_SET:
|
|
- return ntsync_event_set(obj, argp);
|
|
+ return ntsync_event_set(obj, argp, false);
|
|
case NTSYNC_IOC_EVENT_RESET:
|
|
return ntsync_event_reset(obj, argp);
|
|
+ case NTSYNC_IOC_EVENT_PULSE:
|
|
+ return ntsync_event_set(obj, argp, true);
|
|
default:
|
|
return -ENOIOCTLCMD;
|
|
}
|
|
--- a/include/uapi/linux/ntsync.h
|
|
+++ b/include/uapi/linux/ntsync.h
|
|
@@ -53,5 +53,6 @@ struct ntsync_wait_args {
|
|
#define NTSYNC_IOC_MUTEX_KILL _IOW ('N', 0x86, __u32)
|
|
#define NTSYNC_IOC_EVENT_SET _IOR ('N', 0x88, __u32)
|
|
#define NTSYNC_IOC_EVENT_RESET _IOR ('N', 0x89, __u32)
|
|
+#define NTSYNC_IOC_EVENT_PULSE _IOR ('N', 0x8a, __u32)
|
|
|
|
#endif
|